BUG: Switching between painting and erasing

I think this might already be tracked/adressed, just wanna make sure:

Switching between paint mode with B and Erase mode with E is currently bugged.
While reassigning the “change environment” hotkey from B to say CTRL SHIFT B makes the default hotkey work again, it still doesn´t correctly switch to erasing, its erratic/seems like it reacts to pressure, but simply doesn´t correctly switch to erasing, I keep getting paint strokes in between.

Thanks for your post! I’ve raised it internally to see if we can look into it further.

Yeah, seems definitely broken. Also happens on my other workstation.
ONLY happens with pen and when pressure sensitivity is on, NOT on mouse or with pressure sensitivity off.
Seems a few other issues are related to pressure sensitivity as well.

Yep. Also doesnt work in new release from today.
Works with pen AND pressure sensitivity off, doesn´t work with pen AND pressure sensitivity ON.
Tried both on windows 10´workstation with wacom intuos pro m and hp spectre+windows 11+hp tilt pen.

Thanks for the update. I was able to reproduce this and we’ll continue to look at this internally.

1 Like

I just got my wacom bamboo ink pen from amazon, looks like it has the same issues.
But also has the same issues in blender, that my hp tilt pen has.

Pen/tablet protocols are a bit messy in general as it seems…
There is windows ink, wintab, wm event, but there is also MPP and there are different MPP versions…the bamboo ink I have has MPP 1.0, the bamboo ink plus has MPP 2.0. But then there is also versions that use Bluetooth and versions that don´t…

I get another pen tomorrow, that uses MPP 2.0 as I´m not just testing it for instamat, the hp pen just has horribly stiff barrel buttons and I need a replacement anyways…

If you get your hands on another pen/tablet combo, it may help tracking the problem down, I´m glad you could at least reproduce it, so I know its not JUST my hardware/system and I hope its also related to the other issues…:slight_smile:

1 Like