Constant Crashes on MacOS using File Dialog

Hi, InstaLOD studio for MacOS is constantly crashing involving most anything to do with the file dialog. For instance, when trying to import a base color texture for a material, clicking the browse icon opens the dialog. You can click once, maybe twice but then it crashes the entire program. Same thing for browsing and trying to open files. This is completely unusable right now as I can’t get anything into the software! I’m on a MacBook Pro M2 Max using Sonoma 14.5.

Hello @ARcanist and welcome to our community!

I will report this internally and provide further information once it becomes available.


Thanks Pixby. Someone from Abstract did actually respond on the old InstaLOD forums with this:

Thank you for your post. We moved the InstaLOD Community to the new Abstract Community website at the beginning of 2023, and we stopped maintaining this website one year later. We’ll make sure to close this forum and redirect new users to the new website. I have identified your crash report, and the crash seems to be caused by an issue between the Qt Framework and Accessibility handling in macOS Sonoma. We’re planning to release an update of InstaLOD Studio that is built with a newer version of the Qt Framework very soon, which should resolve the problem. In the meantime, disabling custom options under System Settings->Accessibility could potentially help to work around the crash. Although we were not able to identify the specific settings that trigger the crash, it’s worth noting that the issue does not occur on all Macs. I myself cannot reproduce the crash on a Mac mini M1 with Sonoma 14.5.

To which I replied:

Sorry which settings under Accessibility? I have not modified anything there? Are you referring to “Privacy & Security” perhaps? I tried turning off anything in that tab having to do with InstaLOD and no luck. And when do you think this update will be out? Can’t really use this at all right now and we are dead in the water…

Just want to get all the info in one thread. Please let me know on the above. Desperate for a solution.

Thank you.

1 Like

Thanks @ARcanist for compiling the information from the old InstaLOD forums.

Regarding the Accessibility settings, they are the ones found in the System Settings app under the Accessibility section.

If nothing has been customized, a workaround is to open the files by dragging and dropping them into the viewport.

A new update to InstaLOD, which will fix the issues, is being worked on and will be released as soon as possible.

Thanks again!

Yeah haven’t changed any of those settings. And tried turning off some Privacy & Security settings for InstaLOD and that didn’t work either. I did use drag and drop to get some of the base textures in there but I also need to add a Normal map. When I click the button to “Add Channel” it again brings up a dialog box and crashes instead of just adding the channel so I can drag and drop something there. Just totally stuck until you release an update.

Hello @ARcanist,

Thank you for checking the settings and providing the additional info. I understand what you mean about adding a Normal channel which invokes the file picker.

We are focusing on releasing the next update very soon.

Thank you for your patience and support.