Having trouble with Material Merge in Unreal Engine 5

Hey guys, before anything amazing work with this instaLOD!! Congratulations and thank you …

Using UE plugin not instaLOD studio!
I need help because the material merge makes materials of very different quality from the original.

my mesh:

after using the material merge:

1st problem… Emissive material never works in the merged material Why? I have to create new material if emissive in the merge!

final result:

Any one can help me please!! i just want to merge materilas without losing the textures!

this is a big diference!

Hello @VascoReis and welcome to our community!

I have renamed your thread to better describe its contents and will bring up your issue internally.


@VascoReis are you able to send the model for internal testing? If you’d like you could send a private message to me by clicking my name and choosing “Message”.

@pixby I don’t have the option “message” ?! Why?
but I’m working in Unreal Engine Plugin … if I export he will export without materials! Can we have a very very fast call to show you? maybe easy for both!

@VascoReis There should be a blue “Message” button after clicking on my username. This should allow you to send a private message.

Could you provide us with a new blank UE project with the meshes and materials imported and assigned? Also, what version of Unreal Engine are you using?


yes i will create a project and put there one exemple …

1 Like

I see. I’ll look into the message functionality internally. Thanks for bringing this up.

@VascoReis I’ve sent you a personal message testing to see if it works. Could you confirm if you have received it?


Thank you for sending the project. We are currently looking at it internally and will get back when more information is available. Regarding your licensing question, I would recommend either creating a new post in our community forum or contacting our Business Relations team at hello@InstaLOD.com.

1 Like

Hello @VascoReis,

Thank you for your patience while we have investigated this issue.

The issue happens because UE changed the sampler type that is necessary to render emissive textures correctly. To change the sampler type you need to navigate to the InstaLODFlattenMaterial asset, found in “Plugins/InstaLOD for Unreal Engine Content”. Or alternatively through selecting the parent material of your newly created material instance:

If the material is selected the Unreal Engine material editor should open and the emissive sampler type needs to be changed from “Linear Color” to “Color” :

After saving the parent material, the model should render the material correctly.

This will be fixed in the next update.


Thank you very much i will try that for the emissive.
Can you please send me the print of the setting not to lose quality? Like full quallty merge material … That is what i really need and is my big problem…


With instaLOD

Even in the project i send that happen…

Hello @VascoReis,

When merging materials this requires re-packing the mesh’s UVs to fit within the 0-1 space. This can result in a change in texel density requiring a higher resolution texture to compensate. Also, using too many materials will result in degradation as all of them have to fit within the texture space.

It’s possible that the resolution of the Material Merge operation is insufficient to achieve your desired level of quality.

May I ask what Texture Size settings you are using for the Material Merge operation? They can be located under the Bake Output > Material Settings category.