Incorrect result of baking the normal map

I conducted several tests of baking maps, and all the tests showed the same result - incorrect baking in the areas of UV seams. UV is cut along the Hard Edge. Baking settings are standard, and I tried changing various parameters, baking in OpenGL and DirectX, but the result remains the same.

It seems like the issue is not with the geometry, as baking in Marmoset and SP produced correct results.
Geometry files are attached. (2.3 MB)

Hello @gedzillaa and welcome to our community!

In this case you might need to enable the Average Normals toggle in the Advanced Settings section of the Mesh Baking panel.

Unfortunately, it didn’t help. Generally, using ‘average normals’ is intended to improve the baking of surface information, so with this option enabled, chamfers may be baked less accurately. However, I tried it to make sure, and it didn’t help in this case.

I have tested a bake with your provided meshes and have achieved the following results by enabling Average Normals:

If your results are different, could you please provide a screenshot of the result of your bake?

Thank you very much for trying with my geometry. Sherlock inside is becoming more convinced that it is indeed a bug related to hardware or the system.

Adjusting various baking parameters has no effect in trying to remove this artifact, so I can conclude that the issue is not with the settings.

Attached a video of the baking process, showcasing the settings and the result.

Baking in Element Graph leads to a similar result

Thank you for the additional information @gedzillaa. Could you please provide your hardware and software specs for your machine so that I can bring this up internally?

Edit: Can I also ask, does the same behavior occur when switching the Baking Engine to CPU? Was that one of the parameters that you had adjusted when testing?

Yes, this issue occurs on both CPU and GPU engines :slightly_frowning_face:
I’ve tried changing all parameters, including the Baking Engine.


  • CPU: AMD Ryzen 5 3600
  • GPU: Nvidia GeForce RTX 3060, Driver v. 551.52
  • RAM: DDR4 3000Mhz 64Gb


  • Windows 11 23H2, Build 22631.3155
  • InstaMat Studio 2024 EarlyAccess 1 v1.3 (build Jan 24 2024)

Hello @gedzillaa

The issue is that you’re running on an outdated build. This issue was fixed with EA2 that was released a while back.

The Average Normals feature was not working correctly in all cases.

1 Like

Yes, after updating, the issue disappeared. Thank you very much!


Great! Glad to hear it!