M1 iMac keeps crashing when starting to use InstaMat

Does anyone else have this issue. Have just started to learn how to use this exciting software.

Welcome to the community @HarryHarry123 !

Can you provide more details? I’m currently working on a M1 myself and I have no issues at all!

just get the crash system report when importing the .fbx model

  1. Launch instmat
  2. Create a new InstaMat project
  3. Select ‘Layering’
  4. Mesh select - Pick local file - .fbx
  5. Create project without template

then crashes…

Can you share the FBX files with us? Maybe there is something that MAT does not like about it. If you create a project and pick the crate template, does it work?

Are you on the latest version? We had issues with some FBX files when they’re copied to packages.

Finally, there are issues with QT6 and accessibility features in MacOS that can cause crashes. We’re trying to find workarounds for those, but if you have accessibility features enabled, I’d recommend disabling those.


Thank for your help. Have done what you suggested with accessibility and all are turned off. I made a new simple default cube fbx in stable version of blender and tried again last night. Same thing happened.

My Mac is 1st gen M1 on latest Mac OS Sonoma 14.4

Model Name: iMac
Chip: Apple M1
Total Number of Cores:8 (4 performance and 4 efficiency)
Memory: 16 GB
System Firmware Version: 10151.100.753
OS Loader Version: 10151.100.753
Hardware UUID: A5D17F5C-FD96-5F43-A7C9-487817AAA0C0
Provisioning UDID: 00008103-000411CE0ED1001E
Activation Lock Status: Enabled


Made another new fbx and went through the same process but this time as you suggested, choosing the crate template. Again same crash report. Have taken screen grab of what InstaMat says but cant attach here.

I’m currently on MacOS 14.3 on an M1 Max. I think @Pixby is a MacOS user as well.
There must be some setting that prevents MAT from running fine. Can you attach the contents of the crash report here? You might be able to copy and paste the text.

Where do you store the InstaMAT.app bundle? I have no issues in Applications or if it’s on the desktop.

Can you attach your cube here? I can try it on my end.

1 Like


App is on my desktop.

Contents of crash report:
Process: InstaMAT Studio [1860]
Path: /Users/USER/Desktop/InstaMAT Studio.app/Contents/MacOS/InstaMAT Studio
Identifier: com.InstaMaterial.Standalone
Version: ???
Code Type: ARM-64 (Native)
Parent Process: launchd [1]
User ID: 501
Date/Time: 2024-02-11 17:55:25.7638 +0000
OS Version: macOS 14.4 (23E5191e)
Report Version: 12
Anonymous UUID: 8524437C-872A-6872-6202-78AFC9DFA9BC
Sleep/Wake UUID: 8FD93F5A-2A38-4A63-8272-5BE509437E59
Time Awake Since Boot: 2000 seconds
Time Since Wake: 600 seconds
System Integrity Protection: enabled
Crashed Thread: 2 Dispatch queue: com.Metal.CompletionQueueDispatch
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000001280
Exception Codes: 0x0000000000000001, 0x0000000000001280
Termination Reason: Namespace SIGNAL, Code 11 Segmentation fault: 11
Terminating Process: exc handler [1860]
VM Region Info: 0x1280 is not in any region. Bytes before following region: 4297813376
__TEXT 1002b8000-101b18000 [ 24.4M] r-x/r-x SM=COW /Users/USER/Desktop/InstaMAT Studio.app/Contents/MacOS/InstaMAT Studio
Application Specific Information:
abort() called
Thread 0:: Dispatch queue: com.apple.main-thread

Thanks for the update! Is there more to the crash report? Normally there would be a list of threads and functions that could aid us in figuring out what’s going on.


The crash report is too long to paste here (to many characters). I have emailed my contact at Abstract.


Note from mod: an email adress was written here, it was replaced.

Thanks! I’ll try to get a hold of it internally.

Thanks for the crash report @HarryHarry123 !

9 libsystem_platform.dylib 0x18ba7f584 _sigtramp + 56
10 libsystem_pthread.dylib 0x18ba4ec2c pthread_kill + 288
11 libsystem_c.dylib 0x18b95ba20 abort + 180
12 AppleMetalOpenGLRenderer 0x1077aa6d4 invocation function for block in GLDContextRec::flushContextInternal() + 296
13 Metal 0x195db1ae4 MTLDispatchListApply + 52
14 Metal 0x195db1ec0 -[_MTLCommandBuffer didCompleteWithStartTime:endTime:error:] + 492
15 IOGPU 0x1ab497eb8 -[IOGPUMetalCommandBuffer didCompleteWithStartTime:endTime:error:] + 220
16 Metal 0x195db1b78 -[_MTLCommandQueue commandBufferDidComplete:startTime:completionTime:error:] + 108
17 IOGPU 0x1ab499480 __62-[IOGPUMetalCommandBuffer fillCommandBufferArgs:commandQueue:]_block_invoke.50 + 144

It’s a bit weird, what’s crashing here is the viewport - not in the complex execution or data loading of MAT.

The iMac M1 should be identically spec’d as a Mac Mini which we use here internally for development. I’ll try to see if we can set it up to reproduce, is there anything specific about your system? Do you have some apps or tools installed that might intercept and modify rendering? Any hints why this might be different from a vanilla system? We’ve tested on a wide range of mac systems and have not seen an issue yet!

All I can say is that is as to the best of my knowledge there are no apps activated that would affect this. I have yesterday run disk utilities and the disk aid, no faults detected. Also re-installed the Mac OS Sonima 14.4. (Version 14.4 Beta (23E5191e)). Have tried again to run InstaMatt but no cigar.

‘The iMac M1 should be identically spec’d as a Mac Mini’ What does this mean?
I have a M1 (1st gen M1 iMac) Surely your software should work on this? I don’t know anything about Mac Mini.

You run a beta version of MacOS? @Pixby what version are you running?

As stated earlier Version 14.4 Beta (23E5191e)

Don’t know how to install older version OS (none beta)

@voidberg I’m using Sonoma 14.3

I think that might just be the issue! We’re testing on production versions of current previous iterations of MacOS.

1 Like

I have just updated to Sonoma 14.3 this morning

Still crashes.