Mesh Painting & Back Faces

When trying to do mesh painting (Mask or Element Brush) the brush does not ignore backfaces, so trying to paint through the roof of a room will just paint on the roof you cant see instead of the floor you can.
Turning on Backface Culling on the brush itself seem to have no effect.

Welcome to the community @Bamber and thanks for reporting this.

Backface culling seems to work fine on my end around corners:
Screen Recording 2024-01-25 at 15.42.28

Painting from the inside out is indeed incorrect, it doesn’t seem to honor the flag. I think that might be a regression that we did not notice before our launch. I have created a ticket and it’s likely this will be available in the next update.

I think it would be great to add the function of projecting the brush not according to the normals of the object, but according to the viewport camera

Welcome @deadsue! I agree, that’s an awesome feature - and I’m really happy to say that you can already do this. I made a GIF for you, check it out here:
Screen Recording 2024-01-25 at 21.29.52

1 Like