Potential Bug: Instamat crash when using multichannel brush in unified material workflow

Description:
Instamat crashes when trying to use paint brush on a new multi channel brush in the unified material workflow.

Version:
Early access v2

Steps to reproduce:

  1. Create new layering project.
  2. Pick "Multi-Material (Unified)
  3. In the mesh section pick from package and choose “cloth sphere”
  4. Create a new multi-channel-brush layer.
  5. try painting on the cloth sphere: Crash.

Additional Information:
A) This ONLY happens with the cloth sphere (or the meshes with multiple material sections I tried).
B) It does NOT happen with the other template meshes I tried, like the bevel cube or the unit sphere.
C) I can also choose to start with the instamat crate template and then change the mesh to the cloth sphere without crashing, not sure if picking the template to start with actually creates a multi material (unified) project though, that part is a bit confusing.

Thanks for the nicely structured bug-report @insertmesh !

I’ll try to reproduce it right now.

EDIT: I was able to reproduce this with the cloth ball. I’ll file a critical issue internally, it should be resolved with the upcoming build.

1 Like

I’ve tried this with the latest internal build as well, it appears that the issue has been resolved already. Our next build is coming up soon and things will be working as expected with then.

2 Likes